Degraded performance on large long-running jobs
Incident Report for Routific
Resolved
After performing some more large-scale tests, things are running smoothly now. Thanks for your patience!

We'll proceed to build more monitoring tools to notify us when the queue gets clogged up again.
Posted over 2 years ago. Nov 02, 2016 - 18:04 PDT
Update
We have deployed a partial fix, but still need to gather more data and perform more tests to be sure. We are continuing the investigation.
Posted over 2 years ago. Nov 02, 2016 - 15:36 PDT
Identified
We've had huge spikes in large requests in the past few days, affecting anyone who sends large routing requests. We've identified that some of these jobs get stuck in the queue, blocking the way for others. We're working on a fix.
Posted over 2 years ago. Nov 02, 2016 - 08:47 PDT