Customer Management outage

Incident Report for Routific

Resolved

This incident has been resolved.
Posted Jun 18, 2026 - 06:53 PDT

Monitoring

All users should now be able to access customer management.
We are continuing to monitor and will update again in the next hour.
Posted Jun 17, 2026 - 22:09 PDT

Investigating

Access to customer management on app.routific.com and beta.routific.com is not available

It’s our highest priority to get up and running again, and our engineers are working on it. We will send another update in 30 minutes.
Posted Jun 17, 2026 - 21:33 PDT
This incident affected: Routific API, Routific SaaS product, and New Routific.