Live Tracking Disruption
Incident Report for Routific
Resolved
The problem with location tracking on Android devices has been successfully identified and resolved. Thank you for your patience and cooperation.
Posted May 04, 2024 - 22:40 PDT
Investigating
We are currently investigating an issue affecting live tracking for drivers on Android devices.
Posted May 04, 2024 - 22:29 PDT
This incident affected: Driver Mobile App.