SMS deliverability in the U.S.
Incident Report for Routific
Update
SMS deliverability in the United States has improved significantly over the last few days, and we're currently operating at normal deliverability rates. We are continuing to monitor for any further issues.
Posted May 18, 2024 - 13:59 PDT
Update
Our SMS provider has informed us that T-Mobile has lifted the block and we should see gradual improvement in SMS deliverability with that carrier over the next few days. We will continue to monitor the situation and provide another update once we are confident this particular issue has been resolved.
Posted May 16, 2024 - 15:29 PDT
Update
SMS deliverability has stabilized in Canada, and in the U.S. it appears most of the deliverability issues we continue to face are largely due to T-Mobile blocking about ~25% of our SMS messages on their network. We are continuing to lobby our SMS provider for help in unblocking the messages with the carrier. Currently, switching to email notifications or migrating to our new SMS provider (standard messages only) are two options to increase deliverability. Email support@routific.com if you are interested in either of the two options. Thank you for your patience.
Posted May 13, 2024 - 11:07 PDT
Monitoring
Our team has been working on increasing SMS deliverability in the U.S. and Canada over the last few weeks. While we are seeing good progress, some Routific users are still experiencing inconsistent deliverability. We are closely monitoring the situation, and have escalated the issue with our SMS providers. North American telecom companies are increasingly strict on SMS content and perceived spam. We thank you for your patience as we navigate the ever-changing rules and regulations. We will update this page as we learn more.
Posted May 08, 2024 - 15:21 PDT
This incident affects: Twilio SMS and Routific Notifications.