Homepage outage
Incident Report for Routific
Resolved
We have found the cause and fixed our recent homepage outage that prevented users from signing in
Posted Jun 22, 2023 - 06:56 PDT
Investigating
We apologize for the current outage of our homepage. We have identified the issue and have shipped a fix. Please rest assured that we are closely monitoring the situation and will provide updates as soon as we have more information.
You can continue to access Routific through https://app.routific.com/
Posted Jun 22, 2023 - 06:36 PDT