SMS notifications not delivering to US & CA customers
Incident Report for Routific
Resolved
Overall message deliverability in the US and CA is much improved with our new primary SMS message provider, and is stable again with our backup provider. We have improved our capability for message delivery by leveraging multiple providers, and will continue tuning and optimizing delivery to provide the best possible SMS delivery rate for our customers. This incident is resolved.
Posted May 06, 2024 - 17:42 PDT
Update
Between 6:47am PDT and 7:46am PDT, our SMS deliverability experienced delays and has since recovered.
Posted May 06, 2024 - 12:16 PDT
Update
Our systems have alerted us of a possible degradation with SMS deliverability for some customers in the US and Canada. We are working with our SMS service provider to assess the impact and resolve the issue.
Posted May 06, 2024 - 07:31 PDT
Update
While our team has successfully resolved the issue impacting customer notification deliverability, we're continuing to collaborate with our SMS provider to address the challenge of users' ability to send customized messaging.

Thank you for your ongoing patience and cooperation as we make progress towards a resolution.
Posted May 04, 2024 - 22:20 PDT
Update
We are pleased to announce that the deliverability issues affecting standard Routific messages in the US and Canada have been successfully resolved. However, we are still addressing a specific challenge for users sending customized messages.

We are collaborating closely with our SMS provider to thoroughly investigate this issue. In the meantime, we recommend utilizing our standard message templates, which have shown reliable deliverability.

We appreciate your patience and understanding as we work towards a complete resolution.
Posted May 03, 2024 - 16:25 PDT
Update
We are currently experiencing near-normal SMS deliverability rates in the US and Canada. However, we have noted concerns with some valid numbers not receiving messages. We are investigating these reports and have escalated the matter to our providers for swift resolution. Further updates will follow as available.

We appreciate your patience and apologize for any inconvenience.
Posted May 02, 2024 - 18:35 PDT
Update
Some issues with SMS delivery persist in the US and Canada. We are collaborating with our providers and carriers to address these issues and have implemented their recommended adjustments to enhance message delivery. The effectiveness of these changes is being closely monitored, and updates will be provided as progress occurs. We apologize for the inconvenience and value your continued patience.
Posted May 01, 2024 - 16:46 PDT
Update
We have observed some deliverability concerns with both our primary and backup providers that may affect a small percentage of SMS messages in US and CA. Our providers are working with US Carriers to improve this situation. We're very sorry for this ongoing inconvenience.
Posted Apr 30, 2024 - 16:38 PDT
Update
Both primary and backup SMS providers are now online and we’re closely monitoring deliverability on both platforms. Our team has also started to reach out to customers who have customized SMS messages to improve deliverability. Thank you for your patience as we work through the list of those affected.
Posted Apr 29, 2024 - 17:13 PDT
Monitoring
We have continued implementing a migration to a new SMS provider for our US and CA customers. Message deliverability looks good, and all customer messages appear to be getting delivered as expected now. Our customer team will be reaching out to some customers about managing their message template and any customizations, to help ensure you do not experience any future interruption to message delivery. We will continue closely monitoring our SMS delivery status.
Posted Apr 28, 2024 - 18:12 PDT
Update
We have implemented an initial fix which should see some SMS messages now flowing through to CA and US numbers. This involved switching to a new / backup SMS provider for North America messaging. All messaging outside of North America should continue to be unaffected. We are now monitoring the deliverability of this new provider, and if delivery looks good, we will be looking to migrate more of our US and CA SMS traffic to this new service throughout today. We will provide another update soon.
Posted Apr 28, 2024 - 15:45 PDT
Identified
We have identified the cause for the blocking of our SMS notifications and are working closely with our 3rd party provider to resolve the issue as quickly as possible. We hope to be able to restore services soon.
Posted Apr 26, 2024 - 15:36 PDT
Update
SMS notifications to U.S. and Canadian customers are being blocked by our SMS provider. We are very sorry to have this impact your business! It is our top priority to resolve this. In the meantime, we advise you to please switch to email notifications if possible.
Posted Apr 26, 2024 - 10:24 PDT
Investigating
SMS notifications to U.S. and Canadian customers are being blocked by our SMS provider. We are very sorry to have this impact your business! It is our top priority to resolve this. In the meantime, we advise you to please switch to email notifications if possible.
Posted Apr 26, 2024 - 10:23 PDT
This incident affected: Routific SaaS product.