Dispatching Service Disruption
Incident Report for Routific
Postmortem

At 9:27am PST — We had received multiple reports from our customers being unable to dispatch.

After some initial investigation we found this issue had started at approximately 9am PST but our existing systems did not flag this issue for us.

Throughout our investigation we found that a recent release introduced a bug which caused the issue, preventing users from being able to dispatch.

At 9:35am PST — We reverted our services to the previous version to unblock our customers and ensure that dispatching did indeed work again.

Action Items:

  • Our team will look into our monitoring systems to identify why we weren't notified of this issue earlier and fix this gap to ensure that similar issues in the future can be identified and resolved quickly.

We apologize for any impact this had on your businesses today.

Posted Feb 08, 2024 - 18:55 PST

Resolved
This incident has been resolved.
Posted Feb 08, 2024 - 16:03 PST
Monitoring
We have deployed a fix to the related bug and services should be restored. We are monitoring this situation closely.
Posted Feb 08, 2024 - 09:52 PST
Investigating
We introduced a bug with our latest update that impacts dispatching. Our engineers are investigating and will update as soon as its resolved. We are sorry as we know this impacts your business!
Posted Feb 08, 2024 - 09:40 PST
This incident affected: Routific API and Routific SaaS product.