Sending customer notifications will be delayed

Incident Report for Routific

Resolved

Any messages affected by the delay have been processed, and the system has stabilized.
Posted May 22, 2023 - 00:43 PDT

Investigating

We are currently investigating this issue.
Posted May 22, 2023 - 00:18 PDT
This incident affected: Routific SaaS product and Routific Notifications.