Some users may be unable to access New Routific at beta.routific.com.

Incident Report for Routific

Resolved

All Routific systems are now working as expected.
Posted Jul 18, 2025 - 11:57 PDT

Monitoring

Our monitoring shows that the new Routific is available and stable for all users. We are continuing to monitor while working on a mitigation strategy. We will provide further updates as necessary.
Posted Jul 18, 2025 - 09:24 PDT

Update

Some customers are still experiencing intermittent issues accessing the new Routific. We suspect the root cause is a disruption with our cloud provider, and we’re actively working on mitigation steps on our end. We’ll share another update within 30 minutes.
Posted Jul 18, 2025 - 09:00 PDT

Update

We are continuing to investigate this issue.
Posted Jul 18, 2025 - 08:40 PDT

Investigating

It’s our highest priority to get up and running again, and our engineers are working on it. We will send another update in 30 minutes.
Posted Jul 18, 2025 - 08:22 PDT
This incident affected: New Routific.