Customer Notifications may be delayed
Incident Report for Routific
Resolved
We confirmed the delivery times for customer notifications are back to normal and the issues have been fixed.
Posted Dec 11, 2020 - 14:10 PST
Monitoring
We believe we have restored normal delivery times on our customer notifications and recovered from the delays. We will continue to monitor.
Posted Dec 11, 2020 - 10:53 PST
Investigating
We are currently investigating an issue where customer notifications may be delayed in their delivery.
Posted Dec 11, 2020 - 10:12 PST
This incident affected: Routific SaaS product and Twilio SMS.