Unable to load Beta Mobile App (version 2.84.1)
Incident Report for Routific
Resolved
This incident has been resolved.
Posted Sep 28, 2023 - 17:44 PDT
Identified
An issue in the latest version release of the Beta Mobile App has been identified (2.84.1).

We are working on a fix. In the meantime, if you have upgraded to this version and are unable to run the app, please uninstall and reinstall the app.
Posted Sep 27, 2023 - 16:55 PDT
This incident affected: Beta Routific.