Routific (app.routific.com) Outage

Incident Report for Routific

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 13:12 PDT

Monitoring

We have identified the issue and implemented some changes to fix the problem. Routific is currently operational. We will continue to monitor closely to ensure full stability.
Posted Oct 28, 2025 - 16:49 PDT

Investigating

Users are not able to access Routific currently. We are investigating the issue.
Posted Oct 28, 2025 - 16:34 PDT
This incident affected: Routific SaaS product.