We are currently experiencing an outage. Users are not able to optimize routes on beta.routific.com. Its our highest priority to get up and running again. We will send another update in 30 minutes

Incident Report for Routific

Resolved

All Routific’s systems are now working as expected.
Posted Mar 21, 2025 - 16:05 PDT

Monitoring

Optimizations are now working on beta.routific.com again.

For users that were experiencing errors trying to optimize, please re-attempt the optimization.

We are continuing to monitor the results.
Posted Mar 21, 2025 - 13:51 PDT

Identified

The issue has been identified and we are working on a fix for those experiencing errors on existing optimizations. We will provide another update in 30 minutes
Posted Mar 21, 2025 - 13:31 PDT

Update

The ability to optimize new routes on beta.routific.com has been restored. For those still experiencing errors on existing optimizations, please stay tuned
Posted Mar 21, 2025 - 12:58 PDT

Investigating

We are currently investigating this issue.
Posted Mar 21, 2025 - 12:22 PDT
This incident affected: New Routific.