Some dispatchers experiencing issues with real time updates
Incident Report for Routific
Resolved
The issue has been identified and resolved.
Posted Oct 01, 2021 - 10:24 PDT
Investigating
We are currently investigating this issue.
Posted Sep 30, 2021 - 11:48 PDT
This incident affected: Routific SaaS product.