Routific (routific.com) outage

Incident Report for Routific

Resolved

The third-party provider incident has been fully resolved, and our main page is now functioning normally again.
Posted Dec 05, 2025 - 01:20 PST

Investigating

Our main landing page (routific.com) is currently down due to an issue with a third-party provider. The Routific platform itself remains operational.

You can continue using Routific through the following direct links:
• New Routific: https://beta.routific.com
• Old Routific: https://app.routific.com

We’re monitoring the situation and will update this page as soon as the main page is restored.
Posted Dec 05, 2025 - 01:00 PST
This incident affected: Routific SaaS product and New Routific.