Mobile App unavailable on Play Store

Incident Report for Routific

Resolved

The Routific Driver App is available again for download on the Google Play Store.
Posted Aug 02, 2023 - 09:08 PDT

Identified

Our team is working to remediate the situation and make the app available again.
Posted Jul 31, 2023 - 18:30 PDT

Investigating

The Routific Driver app is currently unavailable for download on the Google Play Store.
Our team is working to remediate the situation and make the app available again. In the meantime, drivers who are required to install the app need to use the lite app.
Posted Jul 31, 2023 - 18:29 PDT
This incident affected: Driver Mobile App.