Driver live location not visible on dispatcher map (old Routific)

Incident Report for Routific

Resolved

This issue has been resolved. Dispatchers can see Android drivers' live locations and everything is functioning as expected. Thank you!
Posted Oct 29, 2025 - 16:10 PDT

Identified

Some dispatchers may not see drivers’ live locations after the most recent Android mobile app update. We’ve identified the cause and are working on a fix.

Dispatchers will still be able to see driver status updates and track stop progress.

We’ll provide an update once the fix is live.
Posted Oct 24, 2025 - 13:37 PDT
This incident affected: Routific SaaS product and Driver Mobile App.