A fix has been implemented and we are monitoring the results.
Posted Jun 09, 2025 - 06:51 PDT
Update
We've identified an issue with the service responsible for capturing real-time driver locations. Our team is working on a fix.
Posted Jun 09, 2025 - 06:23 PDT
Identified
We are currently investigating an issue that is affecting the ability to track your drivers’ location in both the Dispatcher view and the Delivery Tracker. We will send another update within the hour.