SMS notifications not delivering to US & CA customers
Incident Report for Routific
Postmortem

Summary

SMS customer notifications to U.S. and Canadian customers were blocked by Routific’s SMS provider from April 20, 2024 at 9:45 am PDT until April 22, 2024 at 2:21 p.m. PDT. SMS customer notifications are now being successfully delivered to U.S. and Canadian customers.

What happened?

On April 21, we were alerted that our SMS provider had suspended our SMS messaging to the U.S. and Canada due to “non-compliant A2P messaging”, which means that some of the messages being sent from the Routific platform were not compliant with guidelines meant to protect customers from unwanted or unlawful messaging. We immediately reached out to the SMS provider and worked with their team to reverse the suspension.

What are we doing next?

Routific is committed to improving the reliability and stability of our systems. To prevent such an incident from occurring in the future, we are looking into ways to implement fallback measures should there be an issue with our SMS campaigns again. We also need to improve our monitoring to detect such service disruptions earlier.

Looking ahead, we also need to protect our customers relying on SMS notifications by ensuring the Routific platform better enforces A2P compliance, thereby increasing deliverability of lawful and important updates.

Posted Apr 23, 2024 - 10:19 PDT

Resolved
SMS customer notifications are now being successfully delivered in both the U.S. and Canada. We will post more details on the cause of the outage and resolution soon. We understand how frustrating this experience has been for all. We thank you for your patience and understanding.
Posted Apr 22, 2024 - 14:42 PDT
Update
We are currently working with our SMS provider to restore SMS customer notifications. We understand this impacts your business, and we appreciate your patience while we actively work to find a solution. Please switch to email notifications for the time being, if possible. We will update this thread tomorrow with further developments.
Posted Apr 21, 2024 - 20:52 PDT
Investigating
SMS notifications to U.S. and Canadian customers are being blocked by our SMS provider. We are very sorry to have this impact your business! It is our top priority to resolve this. In the meantime, we advise you to please switch to email notifications if possible.
Posted Apr 21, 2024 - 15:41 PDT
This incident affected: Routific SaaS product.